Skip to content

SSL with DNS challenge fails due to propagation but ee thinks it renewed #1736

Description

@GreenLondon

Due to cloudflare we are using the DNS challenge method in order to renew the letsencrypt certificate of the site.

Even though the renewal has failed due to DNS records not being propagated, easyengine thinks that the SSL certificate has been renewed causing issues later on.

Issues such as not renewing the certificate when needed so the certificate expires. Not allowing to force renew so we have to delete the site and re-upload it.

All the issues cost money because of the time spend.

`ee site ssl-renew www.example.com
Starting SSL cert renewal
Loading current certificate for www.example.com
Loading current certificate for www.example.com
Created DNS record: _acme-challenge.example.com. with value 4l5Sq1y5bUzcDcmcIPTOj6aP1zzUOQYoSjR7CT_0pmA.
Created DNS record: _acme-challenge.www.example.com. with value zGav80pE1TgvEKR94QSemDq7wFA2qz1LnutSzdBNDaE.

Waiting for DNS entry propagation.
Starting SSL verification.
Warning: The dns entries have not yet propogated. Manually check:
host -t TXT _acme-challenge.www.example.com
Before retrying ee site ssl www.example.com
Warning: Check logs and retry ee site ssl-verify www.example.com once the issue is resolved.
Starting site's services.
Success: SSL renewal completed.`

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions