Skip to content

int32 format not enforced in parameters #320

Description

@cboitel

Given the following parameter definition:

    - name: offset
      description: Index of the first record to return (zero-based).
      in: query
      schema:
        type: integer
        format: int32
        minimum: 0
        default: 0

I would expect myint=2147483648 to be rejected since int32 is OAS format not deprecated https://spec.openapis.org/registry/format/index.html

Activity

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Metadata

Metadata

Assignees

No one assigned

    Labels

    No labels
    No labels

    Type

    No type

    Projects

    No projects

      Milestone

      No milestone

      Relationships

      None yet

      Development

      No branches or pull requests

      Issue actions